Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
quick macros lags sandboxie
#1
Hello,

yesterday I was crazy with my Windows 7 installation and sandboxie.

I use sandboxie to navigate, and the keyboard lag was annoying. Chrome executed in the sandbox was lagged while using the mouse too (just drag and drop the right navigation scrollbar in a large page to see what i mean).

After exit Quick Macros, the navigator back to life. Keyboard is responsive like when chrome is executed outside the sandbox. I have to close the execution from the tray, does not worked to disable all the macros, i have to exit the process.

This morning i tryed to reproduce this behaviour with my windows xp computer, and I have the same problem.

Anybody else can reproduce this?

sandboxie is this software: http://www.sandboxie.com its a sandbox that isolates the execution of another application.

thanks in advance.
#2
I'll test it.
Try to uncheck low level hooks in Options -> triggers.
#3
I tryed this already... but it not worked. :?
#4
The problem actually is in Sandboxie. It intercepts/disables keyboard, mouse and other hooks that are loaded into the sandboxed process, and does it too slowly. Hooks are essential part of triggers and some other QM features. Next QM version will have better compatibility with Sandboxie. Will need to check all low-level hooks checkboxes in Options/Triggers. Next beta will be released this month, maybe tomorrow.
#5
Sorry for resurrecting an old thread, but has a fix been found?

Sandboxie still slows down my macro. I tried:

options > triggers tab > uncheck mouse and keyboard under "use low level hooks"
options > triggers tab > check on "other" under "use low level hooks"
#6
If key is slow with sandboxed programs, try
opt keysync 2

Macro Macro2760
Code:
Select All      Help
act "Chrome"
opt keysync 2 ;;or 1, but it is less reliable in most cases
key "The quick brown fox" T "jumps over the lazy dog"

By default QM uses a hook to make key more reliable, ie to synchronize it with the target program. But Sandboxie disables the hook, and it makes key slow.
Hooks are not used with opt keysync 2. Next QM probably will have an option to use this synchronization method as default.
#7
It works great. Thank you, Gintaras!!
#8
Quote:Next QM probably will have an option to use this synchronization method as default.
I forgot about RtOptions. Put this code in function init2 or in some other function that runs at QM startup. It makes opt keysync 2 default. Don't need in exe.
Code:
Select All      Help
RTOPTIONS x
x.opt_macro_function.keysync=2
x.opt_autotext.keysync=2
x.opt_menu_toolbar.keysync=2
RtOptions 64 x
#9
Oh, interesting. Will this affect my other existing macros that are not inside Sandboxie?
#10
yes
#11
Sorry for my dumb reply. I meant to ask - will this change break any of my existing macros?
#12
Possibly. Unlikely. But if you have many macros, some of them possibly will become less reliable.
#13
Ok. Thank you.


Forum Jump:


Users browsing this thread: 1 Guest(s)