Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
QM toolbar - click button, get 'cannot paste' error
In Quick Macros (version on Windows 10 pro, but saw the same problem on earlier QM versions), creating an Autotext list.
I'm in the autotext list at the point I wish to insert one or more key codes.
I click the 'Keys' button on the QM toolbar, and get the 'Keys' popup where buttons can be clicked to add key codes to a textbox at the top of the dialog.
I click on one of the buttons (example: 'Space') and there is a delay of a few seconds, the 'Keys' dialog closes, then QM jumps to system macro 'TO_Keys', stopped at the next to last line, which is
s.setsel (0 he)
In the output window is
Error (RT) in TO_Keys: cannot paste.

When I click on the 'possible reasons' link, 5 possibilities are given:
1 & 2 - not editable or doesn't support ctrl-v <-- I can cut, copy, paste in the textbox used so these don't seem to be the case.
3 - unsupported clipboard format - seems to just be trying to paste a letter there, and I can manually do that.
4 - window is disabled or hung <-- possibly, but why? It isn't hung before I click the button. I can freely type, cut, copy, and paste in the child id 503 Edit textbox before clicking a button.
5 - Window has higher integrity level <-- if I run QM as administrator, it doesn't matter to this problem.

Here's the gotcha -- sometimes the 'Keys' window functions correctly, but usually not.
I have two modern, updated Windows 10 Pro computers with latest version of QM installed/registered.
On the laptop, the 'Keys' window has never malfunctioned for me.
On the desktop, it is rare that it works, and when it does work it's only for a single button click and then the error situation listed above starts happening on the next click. Sometimes the error happens on the first click, sometimes it doesn't, but once the error happens it will keep happening until I terminate QM and restart it. After restarting, the 'Keys' dialog MIGHT work for a single click.

Any clues to help me resolve this? I have confirmed settings are the same on the two machines. I've uninstalled, reinstalled. I've ensured no other applications are running which use keyboard hooks or automate clipboard handling. Both machines have the same set of software installed and running. Both machines are dev computers, used mostly for Visual Studio and Intellij Idea, and the main use I have for the Autotext lists is automated handling of features in those IDEs. One difference between the computers that impacts SOME software is that the laptop only drives the internal monitor, while the desktop has 4 monitors. I have tried the desktop with only one monitor enabled, but that has no impact on the problem.

I can and have certainly been able to work around the inability to use this feature of QM, but definitely would like to find why it works on one computer but not the other one.

Thank you. I don't know why it works on one computer but not the other one, but using setsel in that dialog is a bug. Now I replaced all setsel in System folder to other functions. Until new QM version you can use the attached System.qml file. Exit QM and replace c:\program files (x86)\quick macros 2\system.qml with this System.qml file.

Attached Files
.zip (Size: 626.36 KB / Downloads: 108)
Thank you, Gintaras. Big Grin
I replaced the system.QML with the one you supplied, and after restarting QM the 'Keys' dialog is working correctly on the machine it was failing on previously.
I greatly appreciate the fast response with a working solution.

Forum Jump:

Users browsing this thread: 1 Guest(s)