Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Conflict between Quick Macros and Extended Keyboard Layout
#1
I installed in my Windows system, from the language options in the Control Panel, an “extended” keyboard layout.
It makes me able to type accented vowels by typing ` followed by any vowel.
This has a small conflict with Quick Macros: whenever I restart Quick Macros, the first time I type a simple vowel, I obtain an accented vowel; if I type any other character, sometimes I obtain an unrecognized character.
This happens only with the first character I type after restarting Quick Macros. Starting from the second character, everything works as expected.
Is there a way to avoid this annoyance?
Reply
#2
What is the layout? I want to test, but it's difficult to find such layout. Tested with US-international, but could not reproduce the bug.
My test conditions were:
Windows 10.
Notepad, QM.
e/è, a/à
Tested with LL and non-LL hooks (Options -> Triggers).
Reply
#3
I am using Windows 10 and United Kingdom Extended Layout. I installed this layout by following these passages:

- open the Windows 10 Control Panel
- Language
- click Options, that is to the right side of your installed language
- click on Add an input method
- now choose from the list not “United Kingdom”, but “United Kingdom Extended”. Sometimes I have seen that the input list is a little tricky: it could happen that you will not find the correct entry because the list is not in a correct alphabetical order: you could need to go down beyond the Z letter and see that the list continues after the Z letter, with some more entries, restarting from A.

[Image: uk_ext10.jpg]
Reply
#4
Tested, still cannot reproduce.
Possibly depends on triggers. Try with an empty QM file, without keyboard triggers. To create new empty file: menu File -> Open/New File, choose a folder, enter any name, click Open. Then test after restarting QM.
Reply
#5
I did it: new file, restarted QM, I saw that all my macros were disappeared, as expected; then I opened Windows Notepad, I typed just the letter a, and it appeared à; typed again a, and it appeared a: all subsequent letters, after the first one, are OK.
Did you activate the UK extended keyboard after installing it? Did you test its being really active by typing ` followed by a? If the Extended UK layout is really active, it should give as a result à.
Reply
#6
Yes, activated. In Notepad. Also in QM itself.
` + a = à.
a is always a, never à after restarting QM.
Difficult to fix bugs when cannot reproduce. It is usually unsuccessful, I even don't want to start.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)