Conflict between Quick Macros and Extended Keyboard Layout

Conflict between Quick Macros and Extended Keyboard Layout

Postby don_AC64 on Tue Apr 11, 2017 6:23 pm

I installed in my Windows system, from the language options in the Control Panel, an “extended” keyboard layout.
It makes me able to type accented vowels by typing ` followed by any vowel.
This has a small conflict with Quick Macros: whenever I restart Quick Macros, the first time I type a simple vowel, I obtain an accented vowel; if I type any other character, sometimes I obtain an unrecognized character.
This happens only with the first character I type after restarting Quick Macros. Starting from the second character, everything works as expected.
Is there a way to avoid this annoyance?
don_AC64
 
Posts: 54
Joined: Wed Jun 28, 2006 1:00 pm

Re: Conflict between Quick Macros and Extended Keyboard Layout

Postby Gintaras on Wed Apr 12, 2017 8:11 am

What is the layout? I want to test, but it's difficult to find such layout. Tested with US-international, but could not reproduce the bug.
My test conditions were:
Windows 10.
Notepad, QM.
e/è, a/à
Tested with LL and non-LL hooks (Options -> Triggers).
Gintaras
Site Admin
 
Posts: 10253
Joined: Thu Dec 19, 2002 7:36 pm
Location: Lithuania

Re: Conflict between Quick Macros and Extended Keyboard Layout

Postby don_AC64 on Wed Apr 12, 2017 8:10 pm

I am using Windows 10 and United Kingdom Extended Layout. I installed this layout by following these passages:

- open the Windows 10 Control Panel
- Language
- click Options, that is to the right side of your installed language
- click on Add an input method
- now choose from the list not “United Kingdom”, but “United Kingdom Extended”. Sometimes I have seen that the input list is a little tricky: it could happen that you will not find the correct entry because the list is not in a correct alphabetical order: you could need to go down beyond the Z letter and see that the list continues after the Z letter, with some more entries, restarting from A.

Image
don_AC64
 
Posts: 54
Joined: Wed Jun 28, 2006 1:00 pm

Re: Conflict between Quick Macros and Extended Keyboard Layout

Postby Gintaras on Thu Apr 13, 2017 6:39 am

Tested, still cannot reproduce.
Possibly depends on triggers. Try with an empty QM file, without keyboard triggers. To create new empty file: menu File -> Open/New File, choose a folder, enter any name, click Open. Then test after restarting QM.
Gintaras
Site Admin
 
Posts: 10253
Joined: Thu Dec 19, 2002 7:36 pm
Location: Lithuania

Re: Conflict between Quick Macros and Extended Keyboard Layout

Postby don_AC64 on Thu Apr 13, 2017 5:09 pm

I did it: new file, restarted QM, I saw that all my macros were disappeared, as expected; then I opened Windows Notepad, I typed just the letter a, and it appeared à; typed again a, and it appeared a: all subsequent letters, after the first one, are OK.
Did you activate the UK extended keyboard after installing it? Did you test its being really active by typing ` followed by a? If the Extended UK layout is really active, it should give as a result à.
don_AC64
 
Posts: 54
Joined: Wed Jun 28, 2006 1:00 pm

Re: Conflict between Quick Macros and Extended Keyboard Layout

Postby Gintaras on Thu Apr 13, 2017 5:14 pm

Yes, activated. In Notepad. Also in QM itself.
` + a = à.
a is always a, never à after restarting QM.
Difficult to fix bugs when cannot reproduce. It is usually unsuccessful, I even don't want to start.
Gintaras
Site Admin
 
Posts: 10253
Joined: Thu Dec 19, 2002 7:36 pm
Location: Lithuania


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron